Legacy i-Pilot remote shows an "F" Error on the Screen

If your Legacy i-Pilot Remote shows "F" on the screen, the i-Pilot remote is not able to communicate with the i-Pilot Controller built into the trolling motor. 

  1. Powercycle the motor by turning it off and then turning it back on.
    • On Terrova/Riptide ST from 2016 and earlier (non-Blue Tooth) the main control board only looks for accessories when it first powers up; if the i-Pilot began communicating after initial power up or was installed while powered up, the control board will not recognize it until the next time it powers up. This step may resolve the issue.
    • Re-test for proper remote function. If the “F” is not displayed the i-Pilot is functioning properly. If the “F” or “Motor Error” is still present proceed to Step 2.
  2. Disconnect the i-Pilot system and test the motor for full function using foot pedal
    • If the motor fails to function properly using a foot pedal, resolve all motor issues then retest remote. function prior to proceeding to Step 3.
    • If the “F” message is still present and the motor functions correctly via foot pedal proceed to Step 3.
  3. Disconnect Power to the motor.
    • Check the i-Pilot coil cord network plug connection in the control box/head for corrosion and verify that is fully connected (connected properly there should be no yellow visible between the male and female plug ends).
    • Check the network plug(s) at the Control Board; on Terrova/Riptide ST motors that have CoPilot installed on the alternate network plug disconnect that CoPilot (i-Pilot disables CoPilot function, but if there is a fault in a connected CoPilot it may disable network communication). Verify that the connection to the coil cord is fully seated.
    • Reconnect power and retest.
    • If “F” is no longer showing a loose connection or faulty CoPilot was the cause for the error. If the “F” message is still displayed Proceed to Step 4. If a network plug that was previously connected is going to be left disconnected install a 2320203 Cap Plug on that plug prior to returning the motor to the customer.
  4. Disconnect power to the motor.
    • Disconnect the network cable at both ends of the coil cord and test continuity through each of the 5 pins. If no continuity is present end to end, or any pin has continuity to one of the other pins replace the coil cord.
    • If there is an unused network accessory plug on the control board connect the coil cord to that plug and retest the system. i-Pilot installed motors will never have a use for a second network plug, if this connection does not display “F” this works as a complete repair.
    • If the “F” Message is still displayed replace the i-Pilot Controller (head).
Was this article helpful?
0 out of 1 found this helpful

Articles in this section

See more